开启辅助访问
 找回密码
 注册帐号

扫一扫,访问微社区

问答求助

关注:387

当前位置:游戏蛮牛 技术专区 问答求助

_____________________________________________________________________________________________________________
问答求助版块规则:

  1、问题尽量描述清楚
      2、代码要放在代码块里
      3、附件最好放到云盘,然后把链接放到TXT文档里,上传TXT文档。【最好没有附件,你懂得】
      4、本版块回复不得无意义,如:顶、呵呵、不错......以及擦边!【真的会扣分的哦】严重者,封IP!
      5、问题得到解决,请选择最佳答案。
      6、若问题是你自己解决了,可以联系管理员,返还蛮牛币,写下你的答案,另有蛮牛币奖赏。
_____________________________________________________________________________________________________________
查看: 648|回复: 4

[基本操作] Unity连接数据库问题

[复制链接]  [移动端链接]
5熟悉之中
767/1000
排名
2145
昨日变化
13

1

主题

40

帖子

767

积分

Rank: 5Rank: 5

UID
60027
好友
0
蛮牛币
1002
威望
0
注册时间
2014-12-8
在线时间
292 小时
最后登录
2017-1-19
发表于 2016-9-6 17:05:32 | 显示全部楼层 |阅读模式
5蛮牛币
我已经将System.Data.dll放在了assets文件夹下,在vs中无法引用,Severity Code Description Project File Line Suppression State
Warning  The primary reference "Mono.Data.Sqlite" could not be resolved because it has an indirect dependency on the .NET Framework assembly "System.Data, Version=2.0.5.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" which has a higher version "2.0.5.0" than the version "2.0.0.0" in the current target framework. SQLTEST.CSharp   有这个警告


回复

使用道具 举报

4四处流浪
342/500
排名
6772
昨日变化
2

0

主题

87

帖子

342

积分

Rank: 4

UID
96996
好友
1
蛮牛币
1920
威望
0
注册时间
2015-5-2
在线时间
127 小时
最后登录
2016-10-11
QQ
发表于 2016-9-7 08:43:39 | 显示全部楼层
.net版本依赖库版本不匹配
System.Data的版本比编译Mono.Data.Sqlite时高,其实问题不是太大

回复

使用道具 举报

4四处流浪
380/500
排名
4940
昨日变化
33

10

主题

91

帖子

380

积分

Rank: 4

UID
66514
好友
2
蛮牛币
473
威望
0
注册时间
2015-1-7
在线时间
105 小时
最后登录
2017-1-19
发表于 2016-9-7 11:19:22 | 显示全部楼层
是System.Data.dll版本的问题,你可以从网上下载一个System.Data.dll
可以看看这篇帖子http://blog.csdn.net/alayeshi/article/details/

回复

使用道具 举报

7日久生情
3261/5000
排名
2464
昨日变化
2

3

主题

2436

帖子

3261

积分

Rank: 7Rank: 7Rank: 7Rank: 7

UID
78862
好友
3
蛮牛币
9281
威望
0
注册时间
2015-3-11
在线时间
426 小时
最后登录
2017-1-18
QQ
发表于 2016-9-9 07:09:35 来自Mobile--- | 显示全部楼层
去下载个新的试试

回复

使用道具 举报

3偶尔光临
222/300
排名
7373
昨日变化
5

0

主题

28

帖子

222

积分

Rank: 3Rank: 3Rank: 3

UID
155542
好友
0
蛮牛币
293
威望
0
注册时间
2016-7-6
在线时间
96 小时
最后登录
2017-1-18

一贫如洗

发表于 2016-9-18 17:01:58 | 显示全部楼层
对于Unity连接数据库时,System.Data.dll这个引用无效!你可以看看你的这个引用是哪个版本的?一般情况下是你的引用项版本过高或者过低。

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册帐号

本版积分规则

快速回复 返回顶部 返回列表