游戏蛮牛学习群(纯技术交流,不闲聊):159852603
游戏蛮牛 手机端
开启辅助访问
 找回密码
 注册帐号

扫一扫,访问微社区

问答求助

关注:554

当前位置:游戏蛮牛 技术专区 问答求助

_____________________________________________________________________________________________________________
问答求助版块规则:

  1、问题尽量描述清楚
      2、代码要放在代码块里
      3、附件最好放到云盘,然后把链接放到TXT文档里,上传TXT文档。【最好没有附件,你懂得】
      4、本版块回复不得无意义,如:顶、呵呵、不错......以及擦边!【真的会扣分的哦】严重者,封IP!
      5、问题得到解决,请选择最佳答案。
      6、若问题是你自己解决了,可以联系管理员,返还蛮牛币,写下你的答案,另有蛮牛币奖赏。
_____________________________________________________________________________________________________________
查看: 894|回复: 6

[技术讨论] android打包时遇到错误CommandInvokationFailure: Failed to build apk.

[复制链接]  [移动端链接]
排名
20225
昨日变化
27

2

主题

11

帖子

56

积分

Rank: 2Rank: 2

UID
176264
好友
0
蛮牛币
59
威望
0
注册时间
2016-10-17
在线时间
21 小时
最后登录
2018-8-22
发表于 2018-3-14 02:09:25 | 显示全部楼层 |阅读模式
5蛮牛币
安卓打包时遇到错误,搞了一个晚上实在弄不懂,只好求助各位。这只是个练手用的小demo,打算打成安卓包试试效果,困难重重,安装好了jdk,sdk,又弄好了keystrore,但最后还是出了问题。下面是console的内容:



CommandInvokationFailure: Failed to build apk.
C:/Program Files/Java/jdk-9.0.1\bin\java.exe -Xmx2048M -Dcom.android.sdkmanager.toolsdir="C:/android-sdk\tools" -Dfile.encoding=UTF8 -jar "D:\Unity\Editor\Data\PlaybackEngines\Player/Tools\sdktools.jar" -

stderr[
Exception in thread "main" java.lang.reflect.InvocationTargetException
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:564)
        at SDKMain.main(SDKMain.java:130)
Caused by: java.lang.NoClassDefFoundError: sun/misc/BASE64Encoder
        at com.android.sdklib.internal.build.SignedJarBuilder.<init>(SignedJarBuilder.java:177)
        at com.android.sdklib.build.ApkBuilder.init(ApkBuilder.java:446)
        at com.android.sdklib.build.ApkBuilder.<init>(ApkBuilder.java:422)
        at com.android.sdklib.build.ApkBuilder.<init>(ApkBuilder.java:362)
        at UnityApkBuilder.<init>(UnityApkBuilder.java:214)
        at UnityApkBuilder.main(UnityApkBuilder.java:34)
        ... 5 more
Caused by: java.lang.ClassNotFoundException: sun.misc.BASE64Encoder
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:563)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
        ... 11 more
]
stdout[

]
UnityEditor.Android.Command.Run (System.Diagnostics.ProcessStartInfo psi, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
UnityEditor.Android.AndroidSDKTools.RunCommandInternal (System.String javaExe, System.String sdkToolsDir, System.String[] sdkToolCommand, Int32 memoryMB, System.String workingdir, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
UnityEditor.Android.AndroidSDKTools.RunCommandSafe (System.String javaExe, System.String sdkToolsDir, System.String[] sdkToolCommand, Int32 memoryMB, System.String workingdir, UnityEditor.Android.WaitingForProcessToExit waitingForProcessToExit, System.String errorMsg)
UnityEditor.HostView:OnGUI()



回复

使用道具 举报

排名
16896
昨日变化
11

0

主题

27

帖子

82

积分

Rank: 2Rank: 2

UID
88455
好友
0
蛮牛币
108
威望
0
注册时间
2015-4-1
在线时间
21 小时
最后登录
2018-4-2
发表于 2018-3-14 02:09:26 | 显示全部楼层
JDK退到1.8,不要用最新的,最新的不向下兼容。
[发帖际遇]: 维他奶 乐于助人,奖励 3 蛮牛币. 幸运榜 / 衰神榜

回复

使用道具 举报

4四处流浪
490/500
排名
7579
昨日变化
1

11

主题

130

帖子

490

积分

Rank: 4

UID
75363
好友
1
蛮牛币
274
威望
0
注册时间
2015-2-22
在线时间
195 小时
最后登录
2018-9-20
QQ
发表于 2018-3-14 09:50:29 | 显示全部楼层
不是最新包,或者SDK 不匹配

回复

使用道具 举报

排名
20225
昨日变化
27

2

主题

11

帖子

56

积分

Rank: 2Rank: 2

UID
176264
好友
0
蛮牛币
59
威望
0
注册时间
2016-10-17
在线时间
21 小时
最后登录
2018-8-22
 楼主| 发表于 2018-3-14 12:13:31 | 显示全部楼层
看图说话 发表于 2018-3-14 09:50
不是最新包,或者SDK 不匹配

额。。能具体说说吗?我JDK是9.0.1,SDK下载了安卓8.0和5.0。最新包指的是什么?SDK不匹配是要下什么版本吗?
[发帖际遇]: 豪大大233 乐于助人,奖励 1 蛮牛币. 幸运榜 / 衰神榜

回复

使用道具 举报

7日久生情
1972/5000
排名
1969
昨日变化
6

8

主题

782

帖子

1972

积分

Rank: 7Rank: 7Rank: 7Rank: 7

UID
83438
好友
2
蛮牛币
2060
威望
0
注册时间
2015-3-23
在线时间
532 小时
最后登录
2018-9-21
发表于 2018-3-14 16:54:17 | 显示全部楼层
看看用的Unity的版本
4.6的最高支持jdk1.7   最好用1.7的就够了  或者用1.8的 太高了容易出问题
还需要在Unity中指定jdk路径 以及sdk路径

回复

使用道具 举报

排名
20225
昨日变化
27

2

主题

11

帖子

56

积分

Rank: 2Rank: 2

UID
176264
好友
0
蛮牛币
59
威望
0
注册时间
2016-10-17
在线时间
21 小时
最后登录
2018-8-22
 楼主| 发表于 2018-3-14 16:58:09 | 显示全部楼层
zhulin5230 发表于 2018-3-14 16:54
看看用的Unity的版本
4.6的最高支持jdk1.7   最好用1.7的就够了  或者用1.8的 太高了容易出问题
还需要在U ...

Unity版本是5.4.6.
Unity中JDK和SDK已经指定了路径。
[发帖际遇]: 豪大大233 被钱袋砸中进医院,看病花了 1 蛮牛币. 幸运榜 / 衰神榜

回复

使用道具 举报

5熟悉之中
753/1000
排名
3831
昨日变化
3

8

主题

111

帖子

753

积分

Rank: 5Rank: 5

UID
210360
好友
0
蛮牛币
26
威望
0
注册时间
2017-3-7
在线时间
278 小时
最后登录
2018-9-12
发表于 2018-3-14 17:45:27 | 显示全部楼层
楼上说的你的JDK用的版本太高了懂吗??下载一个1.8的试试

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册帐号

本版积分规则

关闭

站长推荐 上一条 /1 下一条

快速回复 返回顶部 返回列表